Skocz do zawartości


Zdjęcie

Błąd znacznika [codebox]


  • Zamknięty Temat jest zamknięty
11 odpowiedzi w tym temacie

#1 VPN

VPN

    Guru

  • Użytkownik
  • 6923 postów

Napisano 2009.06.07, 21:05

Coś jest nie tak z zawijaniem tekstu w znaczniku codebox, przez co forum się rozjeżdża. Przykład błędu widać tutaj: http://forum.aqq.eu/...;showissue=1424

Tu byłem.


#2 Oconnel

Oconnel

    AQQ Developer

  • Właściciel
  • 4622 postów

Napisano 2009.06.07, 21:09

Czy codebox powinien zawijać wiersze? Moim zdaniem nie.
MyPortalYouTubeTwitter54slty.png

#3 Pbo

Pbo

    Kierownik

  • Przyjaciel
  • 3477 postów

Napisano 2009.06.07, 21:17

Czemu nie? Czasami przez niego forum się rozjeżdża i wygląda to bardzo brzydko i czasami przeszkadza w przeglądaniu. Moim zdaniem powinno zostać to poprawione.

Komunikatory głosowe Ventrilo.TeamSpeak, Mumble

PolscyGracze.pl - wiadomości ze świata gier | Serwer XMPP PGra.cz


#4 VPN

VPN

    Guru

  • Użytkownik
  • 6923 postów

Napisano 2009.06.07, 21:23

Napiszę tak: nie powinien zawijać wierszy, ale jak widać obecnie robi to jakoś źle obliczając szerokość pola, przez co forum się rozjeżdża.

Tu byłem.


#5 Oconnel

Oconnel

    AQQ Developer

  • Właściciel
  • 4622 postów

Napisano 2009.06.07, 21:23

Nie wiem o jakim rozjeżdżaniu jest mowa, na Operze wszystko jest w porządku.
MyPortalYouTubeTwitter54slty.png

#6 VPN

VPN

    Guru

  • Użytkownik
  • 6923 postów

Napisano 2009.06.07, 21:29

Bo Opera czasem ignoruje błędy :P Na Firefoksie i IE jest źle.

Tu byłem.


#7 lsr

lsr

    Czarna legenda forum powraca...

  • Przyjaciel
  • 1246 postów

Napisano 2009.06.07, 21:34

Pod FF pojawia się dolny poziomy suwak. Być może zależy to od przeglądarki i rozdzeilczości ekranu (u mnie FF 3, a rozdzielczość 1680 x 1050). Piszcie więc, czy i wjaki sposób się rozjeżdża oraz dodajcie info o przeglądarce i rozdzielczości ekranu.

6198 zliczonych i pozostawionych postów na starym forum. Więc byle nabijacz nie zrobi na mnie wrażenia. :D


Zapraszam na odnowiony blog: lsr.waw.pl


#8 Gość_EosiX_*

Gość_EosiX_*
  • Gość

Napisano 2009.06.07, 21:40

Codebox nie powinien zawijać wierszy, ale nie powinien rozwalać strony. Powinien mieć poziomy scrollbar i określoną szerokość albo co. U mnie w każdym razie również rozwala się w linku podanym przez VPN i należałoby to naprawić. Gdzie tu jest powitalnia? Bo to mój pierwszy post na tym forum. :P

lsr: Oj, Silverlight, ty nigdy chyba nie dorośniesz. Ładnie tak?

#9 karololszak

karololszak

    podróżnik w czasie

  • Moderator
  • 1562 postów

Napisano 2009.06.07, 21:44

FireFox 3.0.10, rozdzielczość 1280 x 1024. Box rozjeżdża się w poziomie (pojawia się pasek na dole strony i pasek na dole box'u), w pionie trzyma stałą wysokość

Wg. mnie to właśnie powinno być na odwrót - szerokość stała + scroll tylko na dole box'u, a w pionie powinno się poszerzać

#10 stivo

stivo

    mgr inż.

  • Moderator
  • 2184 postów

Napisano 2009.06.07, 22:10

Pod FF pojawia się dolny poziomy suwak. Być może zależy to od przeglądarki i rozdzeilczości ekranu (u mnie FF 3, a rozdzielczość 1680 x 1050). Piszcie więc, czy i wjaki sposób się rozjeżdża oraz dodajcie info o przeglądarce i rozdzielczości ekranu.

1680 x 1050 i bez żadnego rozjeżdżania czy dodatkowych suwaków zarówno w Operze 10, FF 3, jaki i IE8 ;)

#11 lsr

lsr

    Czarna legenda forum powraca...

  • Przyjaciel
  • 1246 postów

Napisano 2009.06.07, 22:30

Aaaa. Zapomniałem dodać, że bok ekranu zabiera mi pasek boczny Visty, więc miejsca w poziomie mam nieco mniej. Po usunięciu paska dolny suwak w polu codeboksa znika.

6198 zliczonych i pozostawionych postów na starym forum. Więc byle nabijacz nie zrobi na mnie wrażenia. :D


Zapraszam na odnowiony blog: lsr.waw.pl


#12 matc

matc

    Libra

  • Przyjaciel
  • 166 postów
  • MiejscowośćBerlin

Napisano 2009.06.08, 03:55

Zasadą jest, że tekst formatowany jako kod nie powinen być łamany (choćby z uwagi na jego czytelność). Dlatego siedzi w <CODE>. Ale, żeby nie było sytuacji takiej jak wyżej - jedna długa niełamana linia rozciąga komórkę - ustawiany jest atrybut CSS overflow: auto... który Opera obsługuje i respektuje, a widać Firefox nie potrafi sobie z nim poradzić.

Efektem jest złe wyświetlanie w Firefoksie i MSIE. Ewidentnie jest to połączenie wrednej niełamliwej długiej linii kodu i albo nieprawidłowego CSS albo braku obsługi danego atrybutu CSS przez przeglądarki.


Update: Problem wydaje się generalnie nierozwiązywalny przy pomocy CSS 2.1, gdyż, żeby zadziałał overflow: auto na Firefoksie (i pewnie nwoszych MSIE), trzeba by ustawić sztywną szerokość (lub maksymalną szerokość) bloku z kodem. A biorąc pod uwagę zmienną szerokość samej strony forum - nie jest to możliwe. Da się to JavaScriptem (jQuery) on-line policzyć i uaktualnić... Takie poprawianie na około, ale działa... poza MSIE .

Ostatnio na forum którym się wypowiadam, jego administrator ładnie to wyjaśnił. Ja także nie mam problemu na Operze. Problem mają i będą mieć użytkownicy przeglądarek Internet Explorer oraz Firefox.
Jesteśmy jak książki...
Większość ludzi widzi tylko naszą okładkę, mniejszość czyta wstęp, wielu wierzy tylko krytykom, nieliczni poznają naszą treść.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych