Skocz do zawartości


Informacje o zgłoszeniu

Potwierdzenia zgłoszenia

  • Tak (0)Nie (0)
Zdjęcie

AQQ używa przestarzałe ciphers i nie obsługuje nowszych

Napisane przez Beherit w 2015.03.22, 18:38

AQQ używa przestarzałe ciphers m.in. RC4, LOW, SEED oraz nie obsługuje nowszych np.

 

ECDHE-RSA-AES256-GCM-SHA384 (0xc030)
ECDHE-RSA-AES256-SHA384 (0xc028)
ECDHE-RSA-AES256-SHA (0xc014)

 

Prośba o poprawę bezpieczeństwa w tej kwestii. Rozwiązanie dla leniwych:

 

http://www.atozedsof...0120905.EN.aspx

 

W skrócie trzeba w komponencie Indy (TIdServerIOHandlerSSLOpenSSL/TIdSSLIOHandlerSocketOpenSSL) ustawić SSLOptions.CipherList i dać np. (tutaj akurat ustawienia mojego serwera XMPP):

 

DEFAULT:!EXPORT:!LOW:!RC4:!SSLv2:!3DES:!SEED:!SRP:!DSS:!ECDSA:!PSK:!kECDH:!CAMELLIA128:!CAMELLIA256-SHA:!AES128-SHA:!AES128-SHA256:!AES128-GCM-SHA256:!AES256-SHA256:!AES256-GCM-SHA384:!DHE-RSA-AES128-SHA256

 

Oczywiście nie można wyłączyć wszystkich metod, bo dużo serwerów olewa bezpieczeństwo i potem połączenie z nimi będzie nie możliwe. Polecam do testów użyć poniższej strony, która pokaże jakie ciphers wskazany serwer:

 

https://xmpp.net/index.php

 

Nie musisz dziękować @Oconnel.


zmienił naprawione w na: 3.0.0.59
zmienił status na: Zrealizowano

Poprawione w wersji wysłanej na priv :)







Użytkownicy przeglądający to zgłoszenie: 0

0 użytkowników, 0 gości, 0 anonimowych